• B
    Britian Wiggs

    So I'm currently doing the maze event and I'm currently stuck, I looked at all possible routes and there legitimately is no way for me to proceed further, there is a catapult blocking the only plausible way out and theres no way to skip past it, help??

    posted in Bugs read more
  • B
    Britian Wiggs

    @Bettina-Löffler sooo, almost a month later, and 3 reports, and still nothing. I received an email asking if my problem had been solved the other day but I still haven't recieved any sort of refund of my gems at all.

    posted in Bugs read more
  • B
    Britian Wiggs

    @Bettina-Löffler so I did as you recommended, however no reply, it's almost been 2 weeks now.

    posted in Bugs read more
  • B
    Britian Wiggs

    I figured out where my gems went, so apparently theres no warning (even if you have the "safety" (thing that notifies you when you are about to spend over 20 gems) on.) If you spend your gems in the portal where you craft dragons with the Crystal's. I had just noticed I have a "fine ruby" without getting the prequesitis. Apparently I had accidentally clicked to spend gems to cover the cost of the other Crystal's. Unfortunate but I guess lesson learned.

    posted in Bugs read more
  • B
    Britian Wiggs

    Hello, so I've been playing for a couple months now, have spent a pretty decent penny, and have started to realize a trend that I figured I may have just been misscounting before, so I have collectively noticed I randomly lose gems here and there, sometimes one or two, sometimes 20+ I do have my setting on to alert me anytime an upgrade or speed up. I legit just saw a gem vanish for absolutely no reason, I hadn't even touched anything, literally logged on and exited out of the extreme amounts of "promotions" and then saw my gem count go from 90 to 89 right before my eyes. I just completed an offer 2 hours ago for 250 gems and suddenly I'm down to 89. So I'm not sure what's happening. No one else has my log in information, I even changed my password twice.

    posted in Bugs read more

Looks like your connection to Socialpoint Forums was lost, please wait while we try to reconnect.