• C
    Chabal

    As gently as possible, I would like to reiterate from other threads, that Phauns is not the problem. The breeding rates for the legends are unobtainable low. With Phauns active 2 days ago, in my breeding tree, I bred a 5* wind + 5* primal - and got no legends in 100 breeds, the last 50 being definitely 44 wind eggs, 3 arctic wind eggs, 3 aerosaur eggs and NO north wind eggs. Phauns tripling nothing is still nothing.

    posted in Breeding Help read more
  • C
    Chabal

    To answer your 2nd question, the last 50 attempts I kept close track of: 5* lvl 31 wind + 5* lvl 31 primal. 44 wind eggs, 3 Arctic wind eggs (vr), 3 aerosaur eggs (epic), ZERO north wind eggs.

    posted in Breeding Help read more
  • C
    Chabal

    I have been polite in called it an unintentional bug. Sanctuary legends have been 25-30% chance forever. Kratus always seemed higher than that, like 35%. Even if the new legend are worse at 15-20%(?), it is not within acceptable results. If they have made some legends ridiculous at less than 1% chance, then they are cheating us.

    posted in Breeding Help read more
  • C
    Chabal

    Rare Breeding is broken. Last month I got acceptable results of getting 21 legend eggs in 40 breeds, and 20 legend eggs in a different 60 breeds. But my in last 100+ breeds have given ZERO legend eggs. You can get Heroic eggs from the breeding event faster than that!!! This is a bug, but every time I try to post it as a bug, they lock or delete my post !!

    posted in Breeding Help read more
  • C
    Chabal

    I have tried for the breeding reborn dragons initially with success. With Phauns tower active and 5* dragons breeding, I was able to gem 21 fertility dragon eggs in about 40 tries. Next, I got 20 Celestial Wind orbs in about 60 breeds. The last two times I have tried, I have gemmed 40 tries each time, and gotten ZERO legend dragon eggs. 0 for 80 or 0 for 85, with Phauns active. How can an increased chance for rare breeds be less than 2% ???

    posted in Bugs read more

Looks like your connection to Socialpoint Forums was lost, please wait while we try to reconnect.