• D
    ddayton

    The game is running extremely slow even with excellent signal. It's not pulling everything up, not giving coins for collecting food and gold for events, and videos will occasionally play but are still restarting. And freezing up for no reason. What's going on? It's. Been a week with some of these issues, and additional issues adds more frustration to what is normally an enjoyable game.

    posted in General Discussion read more
  • D
    ddayton

    Trying to get the soccer dragon through breeding

    posted in Breeding Help read more
  • D
    ddayton

    I'm level 31 and I'm trying to breed my ice dragon to my flame dragon to get the necessary dragon needed to complete a battle that requires this specific dragon I'm trying to obtain through breeding. However, the game won't allow me to obtain the needed dragon through breeding. Both are level 15 and it still won't the breeding of the 2. Am I needing to be at a higher level than 31, or are the dragons I'm trying to breed not at the correct level? Please let me know cuz I'd like to finish this battle.

    posted in Breeding Help read more
  • D
    ddayton

    The game is running extremely slow, not getting coins when collecting gold and food, and haven't been able to watch videos for freebies or anything else for a week and did message the 3rd party on the 1st day of video issues. Any idea on when any of this will be fixed? Extremely frustrating trying to play a game you enjoy when you're not able to enjoy it cuz it's not working correctly.

    posted in General Discussion read more
  • D
    ddayton

    The freebies videos and videos to opt for additional food after battles keeps restarting the game. This has been an issue for 3 days now and no option to report. It just restarts the game as soon as you click on the videos for either. Please fix ASAP.

    posted in Bugs read more
  • D
    ddayton

    For about a week or more I've been having problems with the dragon city game freezing up when viewing the videos to redeem freebies. This is very frustrating being I've got excellent signal and all the time fast data so I know it's not my phone. Please fix this issue soon.

    posted in Bugs read more

Looks like your connection to Social Point Forums was lost, please wait while we try to reconnect.