• M
    Monsterbath

    It's not an issue with my account. As I said before, I was able to pull my account on a tablet, on the chromebook, and on the other phone. All using googleplay. I can pull it up right now on any of those. Besides, it's impossible for it to be my account because these new phones don't even give a chance to type anything in for the game to even know it's me. It's a non-starter. Whether it's your account or the next guy, the phone never gives you a chance to even try. "Connection error" is all you get.

    The first new phone that didn't work was a Galaxy J3 Orbit. The second new phone that didn't work was an LG Rebel 4LTE. Every device is Android, of course.

    posted in General Discussion read more
  • M
    Monsterbath

    I took the phone back. I bought a different phone. Same thing is happening.
    Has anyone out there bought a new phone recently and tried to load their account? What are the odds that I'm the only one that buys 2 phones and it doesn't work both times? I'm not doing anything to these phones, I'm not changing any settings or denying any permissions or anything.

    It worked on my old phone, works on the tablets, works on the chromebook. All devices are Andriod, by the way.

    Not sure what rule my prior post broke, but the whole point was their email to me told me to click on support and seek assistance. My email to them was that I can't click on support because it says "No FAQs found" and gives no option to contact anyone.

    (Yes, I returned a phone, bought another, and took the time to transfer my number and everything, again....all for Monster Legends.)

    posted in General Discussion read more
  • M
    Monsterbath

    Excellent. Will do that. Thank you very much for your help.

    posted in General Discussion read more
  • M
    Monsterbath

    Can't. It says "No FAQs found for this" when I click on support, or updates. So no possible way to even try. Was hoping someone else had run into this issues and could provide some guidance.

    Any other way to contact support, perhaps with my computer at a website or an email?

    posted in General Discussion read more
  • M
    Monsterbath

    I bought a new phone and am trying to connect to my account.
    When I click either "change player" or the button under "google play" it instantly says "connection error" and won't let me proceed. This doesn't happen when I click facebook.

    However, my old facebook account was deleted and I can't link a new facebook account to my account.

    This isn't a problem on any other device, just this new phone. Whether I'm going through cell data or wifi, same thing happens. Is there a setting within googleplay that's causing this or what?

    One thing that seems odd is the message comes up instantly, like it didn't even have a chance to check the connection.

    posted in General Discussion read more
  • M
    Monsterbath

    Would adding text, in addition to pictures, to show us what the breed combos are during breeding events be a good idea?

    Example: Right now, to try and breed Ophi, it's hard figure the name of the monster to the left of Pandalf. Checked your facebook page and found no written information there, nor is there anything about the combos written in text here on socialpoint forums.

    Please provide written instructions in addition to pictures.

    Thanks.

    posted in Events read more
  • M
    Monsterbath

    Doing the numbers on when the limited path ends and discount times, am I correct that the next discount happens exactly when the limited time path ends? Like literally the minute it's over is when the discount happens? Ouch.

    On another note: Do we have a maze picture or chart yet?

    posted in Events read more
  • M
    Monsterbath

    And here it is, right after a breeding event so the hatchery is full. Ouch.

    Why did this event not show up on the calendar posted on the FB page? Can we please have it show up on there in the future?

    posted in Events read more

Looks like your connection to Social Point Forums was lost, please wait while we try to reconnect.