• O
    Old_Soldier

    @frunobulax The only minor point of disagreement I have here is on maxing out your islands. I recommend always saving 1 or 2 spots. That way, if you get a monster you don't have habitat for, you can build what you need.
    Beyond that, I would warn against equipping runes just because you have them. As you pointed out, removing them later can be expensive. I literally just spent over 100 gems, and millions in gold, to remove my mistakes.

    posted in General Discussion read more
  • O
    Old_Soldier

    @Marianne-van-Es So, because it's a 3rd party add-on, it's not your problem? Anything that effects the quality of your game, is YOUR problem. After all, if these issues are widespread amongst players, it won't be this 3rd party's name that gets dragged through the mud.
    Also, sorry about the difficulty in my original post. This forum does that to every OP I make, while my replies work just fine.

    posted in Bugs read more
  • O
    Old_Soldier

    None of the preset questions for support fit my problem. I have already tried restarting my device. I have also tried uninstalling, and reinstalling the game.

    First, I have been playing for quite some time now. But, whenever I click on theview tasks button, I always get the message " no offers available". Second, my "play trailer " button frequently refuses to load in. Then, when it does, I often watch trailers without receiving a reward. It should be noted that these rewardless trailers DO NOT count against the total number of trailers I can watch in a single session, they mearly increase the time it tales me to complete a session. Also, when we have the opportunity to speed up a task, such as breeding, by watching trailers, the buttons for doing so do not function for me. Finally, I sometimes get booted from the game, when opening a trailer, or when entering battle (PvP, and PvE). This is rare, but does happen.
    None of these glitches make the game unplayable. They are just extremely frustrating. I actually love this game, in spite of these annoyances.

    --Text corrected by Haka --

    posted in Bugs read more
  • O
    Old_Soldier

    @Haka-Taka Well, hopefully I won't need to make any new posts any time soon. 😂

    posted in Team Hall read more
  • O
    Old_Soldier

    @Haka-Taka Like I said, tech is a mystery to me. My comments/replies seem to work fine. This only seems to happen when I make a new post. It could be my fault. Probably not many players on here nearing the half century mark.

    posted in Team Hall read more
  • O
    Old_Soldier

    @Haka-Taka Nope. But, no matter where I place the curser, it gets moved to the spot in front of the first word. Then, the words I type show up there, spelled correctly but in reverse order. Weird!

    posted in Team Hall read more
  • O
    Old_Soldier

    @Haka-Taka or, not. It won't let me edit it. I give up. 😢

    posted in Team Hall read more
  • O
    Old_Soldier

    @Haka-Taka That should read 17. I'll fix it. 😂

    posted in Team Hall read more
  • O
    Old_Soldier

    @Haka-Taka Also, could you fix the one I posted in Team Hall? Same issue. Thanks.

    posted in Ideas Generator read more
  • O
    Old_Soldier

    @Haka-Taka Thank you. I thought it was my fault, somehow. I'm nearly 50 years old, and not very tech savvy.

    posted in Ideas Generator read more

Looks like your connection to Social Point Forums was lost, please wait while we try to reconnect.